Xamarin Store reachability issues
Incident Report for Xamarin
Resolved
We've identified and fixed an issue with resource usage on the appserver. Everything is back to normal now.
Posted almost 2 years ago. Nov 27, 2015 - 16:29 UTC
Investigating
We're investigating some reachability issues with the Xamarin Store.
Posted almost 2 years ago. Nov 27, 2015 - 16:18 UTC